Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: <bugzilla-daemon-eaOCjQ5FDoY <at> public.gmane.org>
Subject: [Bug 6620] New: xfce4-genmon-plugin-3.2 fails to build with xfce4-panel-4.7 (missing libxfcegui4 linkage)
Newsgroups: gmane.comp.desktop.xfce.goodies.devel.version4
Date: Sunday 8th August 2010 12:54:05 UTC (over 6 years ago)
http://bugzilla.xfce.org/show_bug.cgi?id=6620

           Summary: xfce4-genmon-plugin-3.2 fails to build with
                    xfce4-panel-4.7 (missing libxfcegui4 linkage)
    Classification: Panel Plugins
           Product: Xfce4-genmon-plugin
           Version: unspecified
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: General
        AssignedTo: [email protected]
        ReportedBy: [email protected]


Created an attachment (id=3064)
 --> (http://bugzilla.xfce.org/attachment.cgi?id=3064)
missing libxfcegui4 cflags/libs

because xfce4-panel-4.7 is using libxfce4ui instead of libxfcegui4, this
needs
to be explicitly defined or the build bails out on:

xfce4_genmon_plugin-main.o: In function `genmon_create_options':
main.c:(.text+0x15dd): undefined reference to `xfce_create_header'
xfce4_genmon_plugin-main.o: In function `About':
main.c:(.text+0x1d2e): undefined reference to `xfce_info'
collect2: ld returned 1 exit status

full build.log is here: 

http://bugs.gentoo.org/attachment.cgi?id=241751&action=view

attached patch solves the issue

-- 
Configure bugmail: http://bugzilla.xfce.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
 
CD: 4ms