bugzilla | 8 Aug 14:54 2010

[Bug 6620] New: xfce4-genmon-plugin-3.2 fails to build with xfce4-panel-4.7 (missing libxfcegui4 linkage)

http://bugzilla.xfce.org/show_bug.cgi?id=6620

           Summary: xfce4-genmon-plugin-3.2 fails to build with
                    xfce4-panel-4.7 (missing libxfcegui4 linkage)
    Classification: Panel Plugins
           Product: Xfce4-genmon-plugin
           Version: unspecified
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: General
        AssignedTo: goodies-dev@...
        ReportedBy: ssuominen@...

Created an attachment (id=3064)
 --> (http://bugzilla.xfce.org/attachment.cgi?id=3064)
missing libxfcegui4 cflags/libs

because xfce4-panel-4.7 is using libxfce4ui instead of libxfcegui4, this needs
to be explicitly defined or the build bails out on:

xfce4_genmon_plugin-main.o: In function `genmon_create_options':
main.c:(.text+0x15dd): undefined reference to `xfce_create_header'
xfce4_genmon_plugin-main.o: In function `About':
main.c:(.text+0x1d2e): undefined reference to `xfce_info'
collect2: ld returned 1 exit status

full build.log is here: 

http://bugs.gentoo.org/attachment.cgi?id=241751&action=view

attached patch solves the issue

--

-- 
Configure bugmail: http://bugzilla.xfce.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Gmane