Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: apallik <apallik-VfP7D1isd+o <at> public.gmane.org>
Subject: Re: 42883:ERROR function does not exist
Newsgroups: gmane.comp.finance.ledger.smb.user
Date: Thursday 5th April 2012 19:10:03 UTC (over 5 years ago)
apallik wrote
> 
> Dear all,
> 
> I have been having the same problem when trying to install in MacOS X (vs
> 10.6.8).
> 
> Actually there are a couple of issues with the latest installation
> recommendations on your site (ie
> http://www.ledgersmb.org/help/install/Install_LedgerSMB_13_Apple_OSX.html)
> 
> First of, let me give you the specifics,
> 
> PostgreSQL vs 9.1.3-1
> Ledgersmb vs 1.3.14
> 
> I have been going through the steps trying to hack the problems
> encountered. I am pretty new to this, however having experience with
other
> programming languages helped identify some of the problems.
> 
> If you follow the installation instructions on your website, the
> postgresql is installed in the Library folder  and not the usr/share/...
> etc folder (unless you modify the path during installation). 
> 
> This changes things quite significantly (especially when modifying the
> ledgersmb.conf file). 
> 
> Anyhow, managed to install that, managed to install Ledgersmb on
> /usr/local/ledgersmb/ (one minor recommendation here is to tell people to
> copy the ledgersmb.conf.template file to ledgersmb.conf file since it
does
> not exist and you get an error during perl Makefile.pl) made all the
> appropriate changes to ledgersmb-httpd.conf file (here you should also
> include in the instructions that you need to change the WORKING_DIR to
the
> path of the ledgersmb folder, it took we a while to figure out and
> correct), and finally got to go through the /localhost/ledgersmb/setup.pl
> up to the point of login in with the postgresql password  and got an
error
> relating to the contrib path. 
> 
> After figuring out that the PostreSQL is not installed in the /usr/share
> folder but in the /Library/... folder, I modified the pointing path
> accordingly (again here you should mention to the instructions to change
> the path to the extensions folder, not the contrib folder and also the
> /Library/... folder not the /usr/... folder). After that, I managed to
get
> to the point of setting up the database and then get the above error.
> 
> I have no clue what to do from here, I am pretty certain that everything
> is pointing to the right path, when I open the error log file from
> ledgersmb there are only 4 lines saying "function does not exist". I
> unistalled and reinstalled everything but nothing changes.
> 
> Any help would be appreciated.
> 


Just looked through the error log file again and the apache log files and
it
turns out that the problem occurs with psql command not found. Even though
when I do echo$ PATH is see that my path is set correctly and when I call
psql from terminal it responds, it seems not to identify the command when
called through the Database.pm file that creates the new database. Hope
this
helps 

--
View this message in context: http://ledger-smb.1045705.n5.nabble.com/42883-ERROR-expected-1-3-12-error-tp5556135p5621251.html
Sent from the Ledger SMB - Users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Better than sec? Nothing is better than sec when it comes to
monitoring Big Data applications. Try Boundary one-second 
resolution app monitoring today. Free.
http://p.sf.net/sfu/Boundary-dev2dev
 
CD: 3ms