Mike Weiblen | 1 May 07:18 2008
Picon

Re: Can't build OSG 2.4 on Windows following GettingStarted guide

Hi Ben,

um ok.  On http://www.openscenegraph.org/projects/osg/wiki/Downloads/Dependencies
the second paragraph (_before_ mention of the almost 3 year old .zip
archive) clearly informs:
<quote>
The most up to date windows dependency package, that is required for
OpenSceneGraph-2.3 and later, is maintained by Mike Weiblen, and can
be download/browsed via svn at:
https://osgtoy.svn.sourceforge.net/svnroot/osgtoy/3rdParty/branches/
</quote>
That is the correct and current URL, many folks have been using it
during the 2.3 development cycle, and have successfully built 2.4.0
with it.  Not sure why you feel you're not able to build 2.4.0.

Also, for the convenience of folks that have difficulty access svn, I
recently posted a .zip snapshot of the currrent 3rdParty.  I annouced
it on this list a day or two ago.  You may find it at
http://mew.cx/osg/  A direct link is
http://mew.cx/osg/3rdParty_Win32binaries_vs80sp1_2008-04-28.zip

That old 2005 .zip was preserved to support folks building older
OSGversions, but since that audience is steadily shrinking, it should
be marked deprecated or removed.

Robert mentioned he would be travelling these few days since the 2.4.0
release, and probably has not seen my recent posts, to update those
wiki pages (which are kept under strict access control, I can not edit
them).   IMHO you're experiencing a bit of propogation delay in
getting all the bits updated after a major release, it doesn't happen
instantaneously.  Thanks for pointing out an area for improvement, and
your patience is appreciated.

cheers
-- mew

On Wed, Apr 30, 2008 at 4:27 PM, Ben Discoe <ben <at> vterrain.org> wrote:
> Following the links from the main OSG site, it leads to the 'downloads' page:
>
>  http://www.openscenegraph.org/projects/osg/wiki/Downloads
>
>  which leads to the 'dependencies' page:
>
>  http://www.openscenegraph.org/projects/osg/wiki/Downloads/Dependencies
>
>  This instructs us to download 3rdParty_Win32binaries_2005_05_10.zip, which contains freetype 2.19,
which OSG 2.4.0 will not build with.  Ref: recent thread below.
>
>  It is pretty bad to have the official wiki page pointing us to files that will not build.  Is there a wiki
update coming soon?  I would really like to be able to build 2.4.0 and am wondering when a link to functional
dependencies will appear.
>
>  Thanks,
>  Ben
>
>  -------------------------
>  Subject: Re: [osg-users] Unresolved symbol in FreeType plugin
>  From: Jean-S├ębastien Guay
>  Sent: Wed, 12 Dec 2007 07:28:29 -0800
>
>  2>FreeTypeFont3D.obj : error LNK2019: unresolved external symbol
>  _FT_Outline_Get_BBox referenced in function "protected: void __thiscall
>  FreeTypeFont3D::init(void)"
>  >
>  > I'm getting this with current SVN and VS2005. Do I need to update my 3rd
>  > party dependencies?
>
>  After updating yesterday I got that same problem, and updating the
>  dependencies to Mike's latest on his SVN (which is freetype235 instead
>  of freetype219) fixed it.
>
>  _______________________________________________
>  osg-users mailing list
>  osg-users <at> lists.openscenegraph.org
>  http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>

--

-- 
Mike Weiblen -- Austin Texas USA -- http://mew.cx/
_______________________________________________
osg-users mailing list
osg-users <at> lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Gmane