Ulf Samuelsson | 15 Mar 23:00 2010

[oe] gnome-mplayer fails to build due to no libstdc++.so.6 instaging (available in cross)

I get the following error message when I include gnome-mplayer in
an image derived from x11-gpe-image.

<snip>
/arm-angstrom-linux-gnueabi/bin/ld: warning: libstdc++.so.6, needed by
<OE>/build/tmp/staging/armv5te-angstrom-linux-gnueabi/usr/lib/libmusicbrainz3.so
not found

There is no "libstdc++.so.6" in
"<OE>/build/tmp/staging/armv5te-angstrom-linux-gnueabi/lib"

There is a "libstdc++.so.6" in
<OE>/build/tmp/cross/armv5te/arm-angstrom-linux-gnueabi/lib

If I move the "libstdc++.so[.6[.0.10]]"  files to the staging directory
the build will complete, and gnome-mplayer runs on the target.

I tried doing
DEPENDS = "libstdc++"
in "libmusicbrainz.inc"
but get a "no buildable provider" error.

I tried
RDEPENDS = "libstdc++"
and then libmusicbrainz completes, but again gnome-mplayer exists with
the error above.

How ensure that staging gets populated with libstdc++ if libmusicbrainz
is used?

--

-- 
Best Regards
Ulf Samuelsson

Gmane