Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: silvioprog <silvioprog-Re5JQEeQqe8AvxtiuMwx3w <at> public.gmane.org>
Subject: =?ISO-8859-1?Q?Re=3A_=5Blazarus=2Dbr=5D_Resolvendo_um_super_problema_de_ins?= =?ISO-8859-1?Q?tala=E7=E3o_do_PostgreSQL_8=2E4_a_9=2E1_no_Windows_7?=
Newsgroups: gmane.comp.ide.lazarus.brazil
Date: Saturday 14th January 2012 18:30:04 UTC (over 6 years ago)
Em 14 de janeiro de 2012 16:22, Jean Patrick
 escreveu:
> Ao tentar instalar o PostgreSQL 8.4 no Windows 7 eu recebia esta
> mensagem de erro: "An error occurred executing the Microsoft VC++
> runtime installer" e ao tentar  instalar o PostgreSQL 9.1 no Windows 7
> recebia a mensagem de erro: "Unable to write inside TEMP environment
> variable path". Eu espremi o Google de todas as formas imagináveis,
> inimagináveis e surrealistas possíveis e o mais perto que cheguei da
> solução foi lendo este post: http://1stopit.blogspot.com/2011/01/postgresql-83-and-84-fails-to-install.html
>
> O post não resolveu o meu problema, mas indicou o caminho da solução.
> O post pede que seja verificado se o arquivo wscript.exe está presente
> e pode ser executado(se não, o post ensina como ativá-lo). No meu
> caso, estava ativado sim. Então o post prossegue (traduzido com o
> Google): "Novamente, se o Windows Script Host é ativado e instalação
> do PostgreSQL ainda falhar, ela deve estar relacionada a alguma outra
> coisa que eu não encontrei." Quase desanimei por completo.
>
> Porém, mais adiante no post, encontrei o seguinte comentário
> (traduzido com o Google): "PS Não me ocorreu que o WSH pode ser
> ativado, mas a associação entre WSH e arquivos *.vbs pode estar
> faltando. Na verdade, é uma possibilidade. Graças a Diego, Rain e
> comentadores anônimos para apontá-la para fora."
>
> Então, fuçando aqui e ali, descobri que o instalador do PostgreSQL
> copia para a pasta TEMP o arquivo prerun_checks.vbs e é em torno deste
> arquivo que o problema gira.
>
> Portanto, resolvi associar os arquivos .vbs ao wscript.exe .
> Resolvido: NÃO! Ao tentar executar um arquivo com a extensão .vbs
> recebia a mensagem de erro: "Não há mecanismo de script para a
> extensão de arquivo .vbs".
>
> Mais alguns minutos no Google e encontrei o seguinte post:
> http://mndti.com/dicas/1073-nao-ha-mecanismo-de-script-para-a-extensao-de-arquivo-vbs
>
> Ele mostra que basta abrir um Prompt do DOS e executar os dois
> comandos abaixo:
>
> assoc .vbs=VBSFile
>
> ftype vbsfile=%SystemRoot%System32WScript.exe "%1" %*
>
> Agora, os .vbs serão executados normalmente. E o instalador do
> PostgreSQL estará funcionando.
>
> Eu fiquei eufórico quando tudo funcionou. Ufa!
>
> PS: Se alguém souber de um post que explique como solucionar estes
> problemas de instalação do PostgreSQL da forma como expliquei, posta
> aqui porque eu não encontrei.
>
> Att.:
>
> Jean Patrick.

Que estranho, eu sempre instalo e o pacote não é MSI. Também já
instalei sem problema via modo de texto.

Um pequeno detalhe, sempre que vou instalar o PG no win7 desativo a
UAC e abro o setup através do CMD executado como ADM.

-- 
Silvio Clécio
====================================
Site - 
LazSolutions - 
====================================

-- 
Você recebeu esta mensagem porque está inscrito no Grupo "Lazarus-BR"
nos Grupos do Google.
Para postar neste grupo, envie um e-mail para
lazarus-br-/[email protected]
Para cancelar a sua inscrição neste grupo, envie um e-mail para
lazarus-br+unsubscribe-/[email protected]
Para ver mais opções, visite este grupo em
http://groups.google.com.br/group/lazarus-br?hl=pt-BR
 
CD: 24ms