Valentyn Kamyshenko | 1 Feb 10:33 2009

circular dependencies in cabal

Hello all,

when I tried to install plugins package with cabal, I've got the  
following error:

# sudo cabal install plugins --global
Resolving dependencies...
cabal: dependencies conflict: ghc-6.10.1 requires process ==1.0.1.1  
however
process-1.0.1.1 was excluded because ghc-6.10.1 requires process  
==1.0.1.0

It looks like both versions of process package are currently required:

# ghc-pkg unregister process-1.0.1.0
ghc-pkg: unregistering process-1.0.1.0 would break the following  
packages: haddock-2.3.0 ghc-6.10.1 Cabal-1.6.0.1 gnuplot-0.2  
pandoc-1.0.0.1 Graphalyze-0.5 haddock-2.4.1 kibro-0.4.2  
panda-2008.11.7 (use --force to override)

# ghc-pkg unregister process-1.0.1.1
ghc-pkg: unregistering process-1.0.1.1 would break the following  
packages: haddock-2.3.0 ghc-6.10.1 haskell-src-1.0.1.3 polyparse-1.1  
Graphalyze-0.5 cpphs-1.6 hscolour-1.10.1 haddock-2.4.1 HaXml-1.19.4  
hcheat-2008.11.6 rss-3000.1.0 kibro-0.4.2 panda-2008.11.7  
haskell98-1.0.1.0 hxt-8.2.0 hcheat-2008.11.14 hxt-filter-8.2.0 xml- 
parsec-1.0.3 graphviz-2008.9.20 readline-1.0.1.0 uulib-0.9.5  
derive-0.1.4 hslogger-1.0.6 MissingH-1.0.2.1  
HStringTemplateHelpers-0.0.3 HSHHelpers-0.17 haskell-src-exts-0.4.4  
haskell-src-exts-0.4.4.1 haskell-src-exts-0.4.5 ConfigFile-1.0.4  
HStringTemplateHelpers-0.0.4 haskell-src-exts-0.4.6 kibro-0.4.3  
panda-2008.12.16 HStringTemplateHelpers-0.0.6 SybWidget-0.4.0  
wxcore-0.10.5 wx-0.10.5 xtc-1.0 HStringTemplateHelpers-0.0.8  
wxcore-0.10.7 wx-0.10.6 HNM-0.1 HNM-0.1.1 wxcore-0.10.12 wxcore-0.11.0  
wx-0.11.0 HSHHelpers-0.18 haskell-src-exts-0.4.8 darcs-2.2.0  
hslogger-1.0.7 MissingH-1.0.3 HSH-1.2.6 HStringTemplateHelpers-0.0.10  
HSHHelpers-0.19 hscolour-1.11 HNM-0.1.2 pandoc-1.1 mps-2008.11.6  
hcheat-2008.11.25 panda-2009.1.20 testpack-1.0.0 convertible-1.0.1  
gnuplot-0.3 HDBC-2.0.0 HDBC-2.0.1 HDBC-sqlite3-2.0.0.0 HDBC- 
postgresql-2.0.0.0 (use --force to override)

Any suggestions?

-- Valentyn

Gmane