Florent Becker | 23 Jun 14:06 2011

Darcs 2.8 beta 1 is available

Hi cafe-dwellers,

On behalf of the darcs team, I'm pleased to announce the release of
darcs 2.8 beta 1.
This new darcs is just one cabal install away from you, as you can
install it by:

-cabal update
-cabal install darcs-beta (note this will create an executable named
"darcs", not darcs-beta).

You can then come back to your usual darcs if you needby
-cabal install --reinstall darcs

Alternatively, you can get the source tarball from here:
http://hackage.haskell.org/packages/archive/darcs-beta/2.7.98.1/darcs-beta-2.7.98.1.tar.gz.
More information on the release is available at
http://wiki.darcs.net/Releases/2.8

This is a beta, so bug reports are very welcome.

Highlights of this new version of darcs are:

- a faster and much more readable annotate.

- you can use darcs optimize --http to make darcs get from your
repository over http much faster

- you can now use darcs obliterate -o bundle.dpatch to save some patches
into a bundle while unpulling them. This allows to stash these patches
away while you do something else.

- rollback now has a --no-record option which allows to undo some
changes from a past patch without recording that as a new patch straight
away.

- end of write support of "old-fashionned" repositories. These
repositories are the one darcs-1 used to create, and they have been
replaced by the new "hashed" repositories since darcs-2. You can still
use get, pull and so on from these repositories, but darcs 2.8 will
refuse to write to them.

Enjoy your new darcs,

The darcs team

Gmane