Tony Morris | 20 Nov 12:54 2010
Picon

Re: xmonad-contrib fails to build


On 20/11/10 21:45, Ivan Lazar Miljenovic wrote:
> On 20 November 2010 21:51, Tony Morris <tonymorris@...> wrote:
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Hello,
>> xmonad-contrib 0.9.1 is failing to build with GHC 6.12.1. I was
>> wondering if upgrading to GHC 6.12.3 would fix this. If not, then what
>> other options are there?
>>
>> $ cabal install xmonad-contrib
>> Resolving dependencies...
>> Configuring xmonad-contrib-0.9.1...
>> Preprocessing library xmonad-contrib-0.9.1...
>> Building xmonad-contrib-0.9.1...
>> [  1 of 180] Compiling XMonad.Util.Replace ( XMonad/Util/Replace.hs,
>> dist/build/XMonad/Util/Replace.o )
>>
>> XMonad/Util/Replace.hs:1:0:
>>    Warning: Module `Prelude' is deprecated:
>>               You are using the old package `base' version 3.x.
>>               Future GHC versions will not support base version 3.x. You
>>               should update your code to use the new base version 4.x.
>> [  2 of 180] Compiling XMonad.Util.CustomKeys (
>> XMonad/Util/CustomKeys.hs, dist/build/XMonad/Util/CustomKeys.o )
>>
>> XMonad/Util/CustomKeys.hs:80:23:
>>    Not in scope: data constructor `Reader'
>> cabal: Error: some packages failed to install:
>> xmonad-contrib-0.9.1 failed during the building phase. The exception was:
>> ExitFailure 1
>
> I'm going to randomly guess that this is an mtl-2 problem: cabal
> install xmonad-contrib --constraint="mtl < 2"
>
That got it going, thanks.

--

-- 
Tony Morris
http://tmorris.net/


Gmane