Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Federico Abascal <fedeabascal <at> yahoo.es>
Subject: Genbank query problem
Newsgroups: gmane.comp.lang.perl.bio.general
Date: Saturday 29th September 2012 17:30:20 UTC (over 4 years ago)
Dear colleagues,

I have a script (mitobank.pl) that is used by some people. It is aimed to
retrieve mitochondrial genomes for a given taxonomic id. The problem arose
when, some months ago, the NCBI reorganized the way genomes are queried and
the script no longer worked. I have tried modifying the query string with
no success.

What the script asked for was like:


my $seq;
my $gb = new Bio::DB::GenBank;
my $query = Bio::DB::Query::GenBank->new
(-query   =>(txid314147[Organism:exp] AND mitochondrial[title] AND
genome[ti] NOT plasmid[title] NOT chromosome NOT chloroplast) OR
(txid314147[Organism:exp] AND mitochondrion[title] AND genome[ti] NOT
plasmid[title] NOT chromosome NOT chloroplast),
 -db      => 'genome');

It used to return the list of genomes available for that taxonomic id.
However, the NCBI now returns a different kind of results.
I tried to modify the script and query the "nucleotide" database, but this
does not work properly.

Any one could help me, please?

Thanks in advance,
Federico
 
CD: 715ms