Frej Tulin | 11 Jan 03:53 2013
Picon

stand alone blast plus problem

Hi

I have been trying for a long time to control my blast searches with the
Bio::Tools::Run::StandAloneBlastPlus module.

The module is installed and gets loaded ok.

However, when calling:
my $blast_db = Bio::Tools::Run::StandAloneBlastPlus -> new
(    -db_data => \ <at> seq_arr,
    -create => 1);

$blast_db -> make_db();
----------------------------------------------------------------------
I get this error
------------- EXCEPTION: Bio::Root::Exception -------------
MSG: /home/frej/ncbi-blast-2.2.27+/bin/makeblastdb call crashed: There was
a problem running /home/frej/ncbi-blast-2.2.27+/bin/makeblastdb : Error:
NCBI C++ Exception:

"/am/ncbiapdata/release/blast/src/2.2.27/Linux64-Centos-icc/c++/ICC1010-ReleaseMT64--Linux64-Centos-icc/../src/objects/seq/../seqloc/Seq_id.cpp",
line 1689: Error: ncbi::objects::CSeq_id::x_Init() - Unsupported ID type
ATCG00500.1

STACK: Error::throw
STACK: Bio::Root::Root::throw
/home/frej/perl5/lib/perl5/Bio/Root/Root.pm:472
STACK: Bio::Tools::Run::WrapperBase::_run
/home/frej/perl5/lib/perl5/Bio/Tools/Run/WrapperBase/CommandExts.pm:1012
STACK: Bio::Tools::Run::StandAloneBlastPlus::make_db
/home/frej/perl5/lib/perl5/Bio/Tools/Run/StandAloneBlastPlus.pm:776
STACK: comp2fasta.pl:57
-------------------------------------------------------------------------------------------------------------------------------

The general header format of the fasta files I've tried are
>ATCG00500.1|PACid:19637947
or
>g8540.t1|PACid:26887931

I always get the same message.
I have tried modifying the header by putting 'lcl|' in from but nothing
seems to help.
When I build a database using the makeblastdb directly from the command
line it works ok, it just doesn't work from within bioperl.

How can this be? What am I doing wrong?

helpful for any assistance

best
/frej

--

-- 
Frej Tulin
Fred Cross lab
Rockefeller University

Gmane