Fields, Christopher J | 6 Feb 05:24 2013

Re: dependencies on perl version

On Feb 5, 2013, at 10:11 PM, Leon Timmermans <l.m.timmermans <at> students.uu.nl> wrote:

> On Wed, Feb 6, 2013 at 4:32 AM, Hilmar Lapp <hlapp <at> drycafe.net> wrote:
>> Does anyone know what Ubuntu uses?
> 
> 5.14.2, distrowatch is your friend ;-)
> 
>> I've heard lots of other old version problems with CentOS.
> 
> I know people who still use CentOS 4 in production :-|
> 
>> 8 years is really old, and at some point I fear that weighing backwards compatibility too much just holds
us back in a real detrimental way.
> 
> CentOS 5 is 6 years old (and will be supported another 4), but CentOS
> 6 is 'only' 19 months. perl missing a release in the 5.8-5.10
> timeframe combined with an unfortunate alignment of its release
> schedule with Red Hat's don't do us any favors here.
> 
> Leon

Right, it took ~8 yrs to go from 5.8 to 5.10.  I'd like to point out that Python users are in the same boat: the
Python version for CentOS 5 is 2.4.3, and Biopython requires a minimum of python 2.5 (and recommends
python 2.7).  

We can always state that perl 5.8 is supported for the upcoming Bioperl release, but we're dropping v5.8
support for any future releases.

chris

Gmane