Antony03 | 10 Mar 14:17 2013
Picon

Re: sh: 1: Syntax error: "(" unexpected


Hi! Yes I'm sure, my script is exactly what I posted here. And I run it like
this:
anvin26 <at> anvin26:~/Bureau/emboss$ perl water.pl
sh: 1: Syntax error: "(" unexpected
So, I think there is no ambiguity (I run it like a perl script) and this why
I don't understand why the script is run like a bash script!

Leon Timmermans-2 wrote:
> 
> On Sat, Mar 9, 2013 at 4:56 AM, Antony03 <antony.vincent.1 <at> ulaval.ca>
> wrote:
>> I'm trying to use emboss program (water or needle) with a bioperl script.
>> I
>> got this error when I try the script: sh: 1: Syntax error: "(" unexpected
> 
> The error suggests the script is interpreted by the shell instead of
> perl. Are you sure the hashbang (#!) is the absolute first thing in
> the file. No whitespace or BOM character in the front?
> 
> Leon
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l <at> lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> 
> 

--

-- 
View this message in context: http://old.nabble.com/sh%3A-1%3A-Syntax-error%3A-%22%28%22-unexpected-tp35154292p35155738.html
Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.

Gmane