Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Cerebron Emtadrat <emtadrat <at> yahoo.de>
Subject: Q: cpan installation fails for "core.t"
Newsgroups: gmane.comp.lang.perl.bio.general
Date: Wednesday 5th June 2013 09:32:44 UTC (over 3 years ago)
Dear mailing list,

I'm trying to install Bioperl on a Windows 7 machine running Strawberry
Perl. I've started installation using the cpan tool as described on the
bioperl.org wiki "Installing BioPerl on Unix". One of the failed tests
worries me:

t/Assembly/core.t ............................ 1/890
--------------------- WARNING ---------------------
MSG: Setting end to equal start[1]
---------------------------------------------------

--------------------- WARNING ---------------------
MSG: Setting end to equal start[1]
---------------------------------------------------

--------------------- WARNING ---------------------
MSG: Setting end to equal start[1]
---------------------------------------------------

--------------------- WARNING ---------------------
MSG: Setting end to equal start[1]
---------------------------------------------------

--------------------- WARNING ---------------------
MSG: Setting end to equal start[1]
---------------------------------------------------
t/Assembly/core.t ............................ 246/890 Can't do inplace
edit without backup at Bio/Root/IO.pm line 513.
# Looks like you planned 890 tests but ran 246.
# Looks like your test exited with 25 just after 246.
t/Assembly/core.t ............................ Dubious, test returned 25
(wstat 6400, 0x1900)
Failed 644/890 subtests

Is it ok to install Bioperl anyway?

Thanks for your help!

Cerebron Emtadrat
 
CD: 3ms