Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Cerebron Emtadrat <emtadrat <at> yahoo.de>
Subject: Re: Q: cpan installation fails for "core.t"
Newsgroups: gmane.comp.lang.perl.bio.general
Date: Monday 17th June 2013 08:04:53 UTC (over 3 years ago)
Hi Scott,

Frankly speaking I'm new to BioPerl and don't know if I'll be using
assembly modules. I want to write a script that allows me to parse patent
sequence protocols according to WIPO standard 25 (i.e the parser is ready,
I only need the Bio::Perl objects to put the results into), and to save the
results in a SQLite database. So I rather trust that I'll have to use
Bio/Root/IO.

But thanks anyway!

Best regards



----- Urspr√ľngliche Message -----
Von: Scott Cain 
An: Cerebron Emtadrat 
CC: "[email protected]" 
Gesendet: 15:19 Donnerstag, 6.Juni 2013
Betreff: Re: [Bioperl-l] Q: cpan installation fails for "core.t"

Hi Celebron,

Are those the only failures and are you planning on using the assembly
modules of BioPerl?  If you aren't planning on using them, yes it's safe
to install. 

Scott


Sent from my iPhone

On Jun 5, 2013, at 5:32 AM, Cerebron Emtadrat  wrote:

> Dear mailing list,
> 
> I'm trying to install Bioperl on a Windows 7 machine running Strawberry
Perl. I've started installation using the cpan tool as described on the
bioperl.org wiki "Installing BioPerl on Unix". One of the failed tests
worries me:
> 
> t/Assembly/core.t ............................ 1/890
> --------------------- WARNING ---------------------
> MSG: Setting end to equal start[1]
> ---------------------------------------------------
> 
> --------------------- WARNING ---------------------
> MSG: Setting end to equal start[1]
> ---------------------------------------------------
> 
> --------------------- WARNING ---------------------
> MSG: Setting end to equal start[1]
> ---------------------------------------------------
> 
> --------------------- WARNING ---------------------
> MSG: Setting end to equal start[1]
> ---------------------------------------------------
> 
> --------------------- WARNING ---------------------
> MSG: Setting end to equal start[1]
> ---------------------------------------------------
> t/Assembly/core.t ............................ 246/890 Can't do inplace
edit without backup at Bio/Root/IO.pm line 513.
> # Looks like you planned 890 tests but ran 246.
> # Looks like your test exited with 25 just after 246.
> t/Assembly/core.t ............................ Dubious, test returned 25
(wstat 6400, 0x1900)
> Failed 644/890 subtests
> 
> Is it ok to install Bioperl anyway?
> 
> Thanks for your help!
> 
> Cerebron Emtadrat
> 
> _______________________________________________
> Bioperl-l mailing list
> [email protected]
> http://lists.open-bio.org/mailman/listinfo/bioperl-l
 
CD: 13ms