1 Jul 2006 14:00
Re: Interest in a flyweight library?
JOAQUIN LOPEZ MU?Z <joaquin <at> tid.es>
2006-07-01 12:00:13 GMT
2006-07-01 12:00:13 GMT
----- Mensaje original ----- De: "Steven E. Harris" <seh <at> panix.com> Fecha: Viernes, Junio 30, 2006 7:32 pm Asunto: Re: [boost] Interest in a flyweight library? > Joaquín Mª López Muñoz <joaquin <at> tid.es> writes: > > > Anyway, naming discussions aside, do you see value in such a thing > > being elaborated and eventually proposed to Boost? > > From my brief examination of the implementation and examples > provided,yes, it looks useful. I have no qualms with the idea and > I have full confidence you'll implement it well. > However, I don't think you should > cast the naming problem aside as immaterial. Of course naming issues are important, excuse me if I gave the impression I was belittling your concern. Only that in these preliminary stage I want to gauge people's interest in the stuff, regardless of final names [...] > We're both arguing that there's prior art here to justify the > name. Your implementation includes both a reference mechanism and a > pooling mechanism. "Flyweight" describes the former, but the pattern, > at least by my reading, doesn't speak to comparing candidate instances > and ensuring that there are no duplicates in the pool. That > duplicate-avoidance policy is specifically addressed by interning. I do think the pattern also includes the interning thing, but of cours our readings can differ. I must say in support of your terminology that "flyweight" also covers some aspects I'm uneasy about, namely the intrinsic/extrinsic stuff, which my lib proposal does not endorse nor facilitate --and which I'm not fond of either BTW. > My concern is that I might overlook this library because its name does > not capture what I would value about it most. Clearly I have biases, > having been exposed to the "intern" terminology for years, so perhaps > we can hear from others as to whether the name is appropriate. Yes, this would be good. At the time of my writing this seems like some more people are supporting the intern terminology. It'd be great if name proposals cover these three: lib name/namespace name/main facility So, you'd be supporting something like Boost.Intern / boost::intern / boost::interned<> right? > -- > Steven E. Harris Joaquín M López Muñoz Telefónica, Investigación y Desarrollo _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost