Dan Ross | 24 Aug 21:40 2010

Trying to build pygame with python 2.7 on Mac

Hi all-

I thought I'd try to build pygame with python 2.7 on my Mac running Snow Leopard again. I do have pygame running under python 2.6.

It seems to successfully compile and install, but then when I try to run an game, I get the following:

Traceback (most recent call last):
  File "Wiggy.py", line 10, in <module>
    import pygame
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/__init__.py", line 95, in <module>
    from pygame.base import *
ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/base.so, 2): Symbol not found: _SDL_EnableUNICODE
  Referenced from: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/base.so
  Expected in: flat namespace
 in /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pygame/base.so

Any suggestions/explanations would be appreciated.

Dan


Gmane