Philipp von Weitershausen | 26 Feb 21:54 2006

Five 1.2.1 and 1.3.2 released!

The Five team is happy to announce two bugfixes releases of Five
today, Five 1.2.1 and 1.3.2!

What is Five

Five is a Zope 2 product that allows you to integrate Zope 3
technologies into Zope 2, today.  Among others, it allows you to use
Zope 3 interfaces, ZCML-based configuration, adapters, browser pages
(including skins, layers, and resources), automated add and edit forms
based on schemas, object events, as well as Zope 3-style i18n message

We've tried to keep the Five experience as close to Zope 3 as
possible, so this means that what you learn while using Five should
also be applicable to Zope 3, and viceversa.

More information about Five can be found on our website,

Changes in Five 1.2.1/1.3.2

* Five's traversing machinery now mimicks the ZPublisher correctly:
  When no Zope 3-style view is found, first the object's original
  ``__bobo_traverse__`` is tried.  If that does not exist, Traversable
  resorts to attribute look-up.

* Unit tests that did i18n via Localizer would fail because the
  request attribute that keeps Localizers list of preferred languages
  did not exist.

For more information please consult the changes document,


Five 1.2.1 requires Zope 2.8 and can be downloaded at

Five 1.3.2 requires Zope 2.9 and can be downloaded at

Note that Five 1.3.2 will be included in Zope 2.9.2.

About the Zope 3 Base

Five is part of the *Zope 3 Base* project, which aims to offer an
approachable area for developers of Zope 3 related software. More
about the Zope 3 base and its projects can be found on the project
Zope-Announce maillist  -  Zope-Announce <at>

  Zope-Announce for Announcements only - no discussions

(Related lists - 
 Developers: )