Andrea Scarpino | 27 Feb 16:21 2013

qt4 replaces qt

Hi all,
a new qt4 package has hit [testing] and will replace the current qt package.

qt4 doesn't provide 'qt'; you will need to rebuild EVERY package installed 
from AUR and replace qt with qt4 in the depends array.
Also, I suggest to every maintainer in AUR to remove qt from the depends() 
array when there's qtwebkit or any package that needs qt: if you do that, this 
will require no rebuild as we updated every package in the official 
repositories to use qt4.

Also, we ship the Qt 5.x series in [testing]. Qt 5.x is more modular than 4.x. 
This allow us to have these Qt 5.x packages:
* qt5-base
* qt5-declarative
* qt5-graphicaleffects
* qt5-imageformats
* qt5-jsbackend
* qt5-multimedia
* qt5-quick1
* qt5-script
* qt5-svg
* qt5-tools
* qt5-translations
* qt5-webkit
* qt5-xmlpatterns

Generally you only need qt5-base. But, if you are a Qt developer or you want a 
full installation you can install the whole 'qt' group.

When you install both qt5-base and qt4, qmake will refers to the 5.x version. 
To 'force' Qt 4.x, you can use the qmake4 symlink. There's also moc-qt4, uic-
qt4 and rcc-qt4. We provide these symlinks as they are used by cmake and by 
the configure scripts to locate qt4.

--

-- 
Andrea
Arch Linux Developer


Gmane