Barak A. Pearlmutter | 19 Mar 14:39 2010
Picon

RFH, FTBS on armel of djview4 (4.5-6)

I'm the maintainer of the djview4 package.

It autobuilds fine on everything ... except armel.

  ...
  /usr/bin/rcc -name qdjvuwidget qdjvuwidget.qrc -o qrc_qdjvuwidget.cpp
  g++ -c -pipe -I.././src -I.. -pthread -O2 -Wall -W -D_REENTRANT -DAUTOCONF \
	-DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_STREAM -DQT_NO_DEBUG -DQT_GUI_LIB \
	-DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ \
	-I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork \
	-I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/X11R6/include -I. -I. -o \
	qrc_qdjvuwidget.o qrc_qdjvuwidget.cpp
  /usr/bin/rcc -name qdjview qdjview.qrc -o qrc_qdjview.cpp
  g++ -c -pipe -I.././src -I.. -pthread -O2 -Wall -W -D_REENTRANT -DAUTOCONF \
	-DNDEBUG -DQT_NO_DEBUG -DQT_NO_DEBUG_STREAM -DQT_NO_DEBUG -DQT_GUI_LIB \
	-DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ \
	-I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork \
	-I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/X11R6/include -I. -I. -o \
	qrc_qdjview.o qrc_qdjview.cpp
  g++ -Wl,-O1 -o djview qdjvu.o qdjvuhttp.o qdjvuwidget.o qdjviewprefs.o \
	qdjviewsidebar.o qdjviewdialogs.o qdjviewexporters.o qdjview.o djview.o \
	qdjviewplugin.o tiff2pdf.o moc_qdjvu.o moc_qdjvuhttp.o moc_qdjvuwidget.o \
	moc_qdjviewprefs.o moc_qdjviewsidebar.o moc_qdjviewdialogs.o \
	moc_qdjviewexporters.o moc_qdjview.o moc_djview.o qrc_qdjvuwidget.o \
	qrc_qdjview.o \
	-L/usr/X11R6/lib -L/usr/lib -ldjvulibre -ltiff -lXext -lX11 -lm -lpthread \
	-lQtGui -lQtNetwork -lQtCore
  qdjviewexporters.o: In function `tiffHandler(char const*, char const*, std::__va_list)':
  qdjviewexporters.cpp:(.text+0x1338): undefined reference to `QString::vsprintf(char const*, std::__va_list)'
  collect2: ld returned 1 exit status
  ...

For further details, see
https://buildd.debian.org/fetch.cgi?pkg=djview4;ver=4.5-6;arch=armel;stamp=1268931308

This appears (with a quick search) to be an armel-specific mangling problem,
 http://bugs.debian.org/566259
solved in qt4-x11 4:4.6.2-1.  Which is in experimental, but not unstable,
so the armel autobuilder is using an earlier version.

Is there anything I can do in order to get djview4 to progress?

And if there isn't for now, can I at least just ignore the problem,
confident that the autobuilder will try again one a new-enough qt4-x11
is available on armel?

					Cheers,

					--Barak.
--
Barak A. Pearlmutter <barak <at> cs.nuim.ie>
 Hamilton Institute & Dept Comp Sci, NUI Maynooth, Co. Kildare, Ireland
 http://www.bcl.hamilton.ie/~barak/


Gmane