Greg KH | 22 Sep 22:37 2012

Re: [Q] USB is very slow. Is this a known bug?

On Sat, Sep 22, 2012 at 05:25:33PM -0300, Ezequiel Garcia wrote:
> > Yes, the hardware is broken, the drivers are broken, and I would not
> > recommend anyone wanting to do any real USB data transfers to use this
> > platform at all.  Seriously.  Go complain to Broadcom if you want to see
> > this fixed, they are the ones with the specs that we can not get access
> > to.
> >
> 
> Mmmm, I see.
> 
> For some reason (cheapness? crazyness?)
> there are a few users out there wanting to do video streaming
> with their rpi and they want to use stk1160 devices.
> Thus my question.

The answer is, "It will not work, buy a beaglebone or something real if
you wish to do that."

> I don't want to bother you asking: what do you mean by "hw is broken",

Just that, the USB controller in this board can not handle this type of
throughput.  If anyone doubts me, please show me the chip specs that
show me otherwise (yes, this is a ploy to get the specs from Broadcom,
but nothing else seems to work...)

> "drivers are broken"?

The USB driver code is horrible, really really horrible.  Seriously,
it's so bad that no one will touch it, myself included.

> But ... is it related to the fact eth and usb goes through same bus?

Possibly, it's just a really bad USB controller chip, combined with a
sad way to hook it up to the processor, combined with with a truly
horrible driver make for the fact that USB works at all on this board a
total miracle.

And you can quote me on that.

greg k-h

Gmane