Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Dale Blount <linux-kernel <at> dale.us>
Subject: sata_sil problems with recent kernels
Newsgroups: gmane.linux.kernel
Date: Friday 23rd February 2007 17:00:27 UTC (over 9 years ago)
Hi,

Excuse me if this has been covered or fixed, I couldn't find anything in
the archives.

I upgraded from 2.6.11.7 to 2.6.20.1 today and found all the drives
connected to 2 brands of sata_sil sata controllers not working.  The
drives are also (now) of various brands, Maxtor 300GB and 500GB
Seagates.

On boot (or after modprobing sata_sil if not configured to load in my
initrd), I get the below messages in dmesg and no drives showing up
in /dev.

There's 4 drives total, and 6 BUGs so I'm a little confused.  One of the
drive (old sdb, which happened to be the first drive on sata_sil
controllers) is known to have bad sectors, but I didn't think it could
cause this... I'm away from the machine currently, so I haven't tested a
single drive to see if it fails also.

I rebooted back into 2.6.11.7 and everything was peachy (minus the known
bad disk).

Any suggestions or hints to more data I could provide to be diagnosed?

Thanks,

Dale

***************

ata3: SATA max UDMA/100 cmd 0xF8848080 ctl 0xF884808A bmdma 0xF8848000
irq 18
ata4: SATA max UDMA/100 cmd 0xF88480C0 ctl 0xF88480CA bmdma 0xF8848008
irq 18
scsi2 : sata_sil
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata3.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata3.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] __wake_up_common+0x39/0x70
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata3.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata3.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] __wake_up_common+0x39/0x70
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata3.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata3.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
scsi3 : sata_sil
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] __wake_up_common+0x39/0x70
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata4.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] __wake_up_common+0x39/0x70
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata4.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
BUG: at drivers/ata/libata-core.c:4365 ata_hsm_move()
 [] ata_hsm_move+0x1be/0x7d0 [libata]
 [] schedule_timeout+0x52/0xd0
 [] __wake_up_common+0x39/0x70
 [] process_timeout+0x0/0x10
 [] ata_pio_task+0x27/0x100 [libata]
 [] run_workqueue+0x93/0x140
 [] ata_pio_task+0x0/0x100 [libata]
 [] worker_thread+0x147/0x170
 [] default_wake_function+0x0/0x10
 [] worker_thread+0x0/0x170
 [] kthread+0xbb/0xf0
 [] kthread+0x0/0xf0
 [] kernel_thread_helper+0x7/0x18
 =======================
ata4.00: zero err_mask for failed internal command, assuming
AC_ERR_OTHER
ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
 
CD: 3ms