Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Marc Ferland <marc <at> mferland.net>
Subject: xorg7 metapackage install failure
Newsgroups: gmane.linux.lfs.automated
Date: Thursday 26th November 2009 21:47:38 UTC (over 6 years ago)
Hi,

I've completed the LFS guide using the ALFS scripts and have now moved on
building xorg7 using the same technique. I've read the README.BLFS file and
selected the xorg7 meta package from the menu. Everything is fine until the
script tries to resolve the dependencies. More precisely:

*** End of JHALFS configuration.
CONFIG_XORG7
TARGET............ 
DEP_LEVEL......... <1>
SUDO.............. 
PRINT_SERVER...... 
MAIL_SERVER....... 
GHOSTSCRIPT....... 
KBR5.............. 
X11............... 
------------------------------------------------------------------------------

Are you happy with these settings? yes/no (no): yes

------------------------------------------------------------------------------

`./libs/xorg7.dep-MOD' -> `./libs/xorg7.dep'
	Generating xorg7 dependencies tree ...

call: 1 xterm2
call: 2  xorg7-lib
call: 3   libXdmcp
 ret: 3   libXdmcp  Using libXdmcp Xinc to solve xorg7-lib
call: 3   fontconfig
 ret: 3   fontconfig  Using fontconfig Xinc to solve xorg7-lib
 ret: 2  xorg7-lib  Using xorg7-lib Xinc to solve xterm2
 ret: 1 xterm2  Using xterm2 Xinc to solve xorg7
call: 1 xorg7-driver
call: 2  xorg7-server
call: 3   xkeyboard-config
call: 4    xorg7-app
call: 5     xbitmaps
call: 6      xorg7-util
 ret: 6      xorg7-util  Using xorg7-util Xinc to solve xbitmaps
 ret: 5     xbitmaps  Using xbitmaps Xinc to solve xorg7-app
 ret: 4    xorg7-app  Using xorg7-app Xinc to solve xkeyboard-config
call: 4    intltool
 ret: 4    intltool  Using intltool Xinc to solve xkeyboard-config
 ret: 3   xkeyboard-config  Using xkeyboard-config Xinc to solve
xorg7-server
call: 3   xorg7-font
call: 4    xcursor-themes
 ret: 4    xcursor-themes  Using xcursor-themes Xinc to solve xorg7-font
 ret: 3   xorg7-font  Using xorg7-font Xinc to solve xorg7-server
 ret: 2  xorg7-server  Using xorg7-server Xinc to solve xorg7-driver
 ret: 1 xorg7-driver  Using xorg7-driver Xinc to solve xorg7
call: 1 luit
 ret: 1 luit  Using luit Xinc to solve xorg7I/O error : Is a directory
../:1: parser error : Document is empty

^
../:1: parser error : Start tag expected, '<' not found

^
I/O error : Is a directory
unable to parse ../
make: *** [menuconfig] Error 6

Anyone having this issue?

I tried removing luit as well as xterm (since it depends on it in the
guide) but I still get the same error.

The error seems to come from the last line of
blfs_root/xorg7/xincludes/xorg7.xinc.tmp:
...
http://www.w3.org/2003/XInclude"
href="../blfs-xml/postlfs/editors/ed.xml"/>
http://www.w3.org/2003/XInclude"
href="../blfs-xml/general/graphlib/libpng.xml"/>
http://www.w3.org/2003/XInclude"
href="../blfs-xml/x/installing/xbitmaps.xml"/>
http://www.w3.org/2003/XInclude"
href="../blfs-xml/x/installing/x7util.xml"/>
http://www.w3.org/2003/XInclude"
href="../blfs-xml/x/installing/x7proto.xml"/>
http://www.w3.org/2003/XInclude"
href="../"/>

Regards,

Marc
-- 
http://linuxfromscratch.org/mailman/listinfo/alfs-discuss
FAQ: http://www.linuxfromscratch.org/faq/
Unsubscribe: See the above information page
 
CD: 17ms