brian mullan | 16 Feb 14:38 2013
Picon

Fwd: x2go Webbrowser Plugin

I have a suggestion regarding "usability"..  
I had a new server to setup so I added x2go ppa and installed the firefox plugin.    

Starting Firefox then going to Tools/Extensions/Plugins I see the newest plugin version is there (see below 1st image).... but clicking on "MORE" on that screen presents the next/2nd Image.

All that screen tells the user is the x2go version number again...?

My suggestion:  looking at that 2nd image .. 
how hard would it be to include the x2go wiki's URL for configuring the x2goplugin & associated website ??

Seems this would enable people that install the x2go plugin to self-directed toward the rest of the "HOW TO" information to enable it (re the website setup)







   1. Re: x2go Webbrowser Plugin (Mike Gabriel)


---------- Forwarded message ----------
From: Mike Gabriel <mike.gabriel-QcRmU36LScxyC2I0vPwN6RvVK+yQ3ZXh@public.gmane.org>
To: Karel <x2go-m7JHi/ng8ZSuvFJfX82//w@public.gmane.org>
Cc: x2go-user-0fE9KPoRgkgATYTw5x5z8w@public.gmane.org
Date: Fri, 15 Feb 2013 16:09:12 +0100
Subject: Re: [X2Go-User] x2go Webbrowser Plugin
On Fr 15 Feb 2013 15:57:39 CET Karel wrote:

what version of the x2goplugin do you have installed? The one that
is shipped with Ubuntu 12.04 or the one we provide via

I think it's with ubuntu.

At my source (plugin) is version 3.99.0.5-1

Yeah that version if broken. In Debian wheezy we have 3.99.2.1-4. That  one is patched to make the plugin work. So in quantal or raring there  should be a fixed version of the plugin (/me ENOTIME to check the  current archive status of Ubuntu distro versions).

Do this for your client system:

  $ sudo add-apt-repository ppa:x2go/stable
  $ sudo apt-get update
  $ sudo apt-get install x2goclient x2goplugin

At my server I see version x2goplugin-provider (4.0.0.1-0~352~lucid1)
where I changed inside file /usr/share/x2go/plugin/x2goplugin.html
server= to my virtual host IP where is x2goserver:i386   4.0.0.0-0~640~precise1

The server side versions are fine!

Mike


<div>
<div class="gmail_quote">
<div>I have a suggestion regarding "usability".. &nbsp;</div>
<div>I had a new server to setup so I added x2go ppa and installed the firefox plugin. &nbsp; &nbsp;</div>
<div><br></div>
<div>Starting Firefox then going to Tools/Extensions/Plugins&nbsp;I see the newest plugin version is there (see below 1st image).... but clicking on "MORE" on that screen presents the next/2nd Image.</div>
<div><br></div>
<div>All that screen tells the user is the x2go version number again...?</div>
<div><br></div>
<div>My suggestion: &nbsp;looking at that 2nd image ..&nbsp;</div>
<div>how hard would it be to include the x2go wiki's URL for configuring the x2goplugin &amp; associated website ??</div>
<div><br></div>
<div>Seems this would enable people that install the x2go plugin to self-directed toward the rest of the "HOW TO" information to enable it (re the website setup)</div>

<div><br></div>
<div><br></div>
<div><br></div>
<div><br></div>
<div><br></div>
<div><br></div>
<br><div class="gmail_quote">

&nbsp; &nbsp;1. Re: x2go Webbrowser Plugin (Mike Gabriel)<br><br><br>---------- Forwarded message ----------<br>From:&nbsp;Mike Gabriel &lt;<a href="mailto:mike.gabriel@..." target="_blank">mike.gabriel@...</a>&gt;<br>To:&nbsp;Karel &lt;<a href="mailto:x2go@..." target="_blank">x2go@...</a>&gt;<br>

Cc:&nbsp;<a href="mailto:x2go-user@..." target="_blank">x2go-user@...</a><br>Date:&nbsp;Fri, 15 Feb 2013 16:09:12 +0100<br>Subject:&nbsp;Re: [X2Go-User] x2go Webbrowser Plugin<br>On Fr 15 Feb 2013 15:57:39 CET Karel wrote:<br><br><blockquote class="gmail_quote">
<blockquote class="gmail_quote">
what version of the x2goplugin do you have installed? The one that<br>
is shipped with Ubuntu 12.04 or the one we provide via<br>
</blockquote>
<br>
I think it's with ubuntu.<br><br>
At my source (plugin) is version 3.99.0.5-1<br>
</blockquote>
<br>
Yeah that version if broken. In Debian wheezy we have 3.99.2.1-4. That &nbsp;one is patched to make the plugin work. So in quantal or raring there &nbsp;should be a fixed version of the plugin (/me ENOTIME to check the &nbsp;current archive status of Ubuntu distro versions).<br><br>
Do this for your client system:<br><br>
&nbsp; $ sudo add-apt-repository ppa:x2go/stable<br>
&nbsp; $ sudo apt-get update<br>
&nbsp; $ sudo apt-get install x2goclient x2goplugin<br><br><blockquote class="gmail_quote">
At my server I see version x2goplugin-provider (4.0.0.1-0~352~lucid1)<br>
where I changed inside file /usr/share/x2go/plugin/x2goplugin.html<br>
server= to my virtual host IP where is x2goserver:i386 &nbsp; 4.0.0.0-0~640~precise1<br>
</blockquote>
<br>
The server side versions are fine!<br><br>
Mike<br><br>
</div>
</div>
<br>
</div>

Gmane