Mathias Ewald | 23 Oct 11:38 2013
Picon

Ubuntu System Upgrade: The following packages have unmet dependencies

Hi, I have x2gobroker running for a while and everything working. Now I 
wanted to patch my Ubuntu:

mathias <at> x2gobroker:~$ sudo apt-get update
...
mathias <at> x2gobroker:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
   x2goserver
The following packages will be upgraded:
   base-files curl dmsetup dpkg gnupg gpgv grub-common grub-pc 
grub-pc-bin grub2-common initscripts libapr1 libcurl3 libcurl3-gnutls 
libdevmapper1.02.1 libxml2 linux-image-3.2.0-4-amd64 perl perl-base 
perl-modules python python-crypto python-minimal sysv-rc sysvinit 
sysvinit-utils x2gobroker-agent
   x2goserver-extensions xserver-common xserver-xorg-core
30 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
The following packages have unmet dependencies:
  x2goserver-extensions : Depends: x2goserver (>= 
4.1.0.0-0~x2go1+wheezy~heuler~20130731~779~build1) but 
4.0.1.6-0~x2go1+wheezy~main~712~build1 is to be installed
E: Internal error, InstallPackages was called with broken packages!
mathias <at> x2gobroker:~$

mathias <at> x2gobroker:~$ cat /etc/apt/sources.list.d/x2go.list
# X2Go Repository
deb http://packages.x2go.org/debian wheezy main heuler
# X2Go Repository (sources)
deb-src http://packages.x2go.org/debian wheezy main heuler
mathias <at> x2gobroker:~$

cheers
Mathias

Gmane