Michael DePaulo | 20 Jul 03:06 2014
Picon

Re: x2go, GLX option

On Thu, Jul 17, 2014 at 11:40 AM, Leopold Palomo-Avellaneda
<leo@...> wrote:
> A Dijous, 17 de juliol de 2014, Michael DePaulo va escriure:
>> On Wed, Jul 16, 2014 at 6:12 PM, Leopold Palomo-Avellaneda
>> <leo@...> wrote:
>> > El Dimecres, 16 de juliol de 2014, a les 14:55:59, Michael DePaulo va
>> > escriure:
>> >> On Jul 16, 2014 11:44 AM, "Leopold Palomo-Avellaneda" <leo@...>
[...]

>> > Also, I have solved this, but I still have problems with some software
> that
>> > under a remote virt-manager is working but not under x2go.
>> >
>> > If I run a graphical python qt program I got:
>> >
>> >
>> > python: Fatal IO error 11 (Resource temporarily unavailable) on X server
> :5
>> >
>> >
>> > and if I run for instance gazebo, I got:
>> >
>> > X Error of failed request:  BadMatch (invalid parameter attributes)
>> >   Major opcode of failed request:  147 (GLX)
>> >   Minor opcode of failed request:  5 (X_GLXMakeCurrent)
>> >   Serial number of failed request:  22
>> >   Current serial number in output stream:  22
>> >
>> > Any idea?
>>
>> We've disabled GLX by default because It causes many applications to
>> not work. The reason is that our "X server", nxagent 3.5.0.x, is based
>> on X.org 6.9, from 2005. Therefore, nxagent implements a very old
>> version of the GLX protocol. Many apps try to use it, but require a
>> newer version of the GLX protocol, and thus fail.
>> You can read more about this problem here:
>> http://wiki.x2go.org/doku.php/doc:de-compat
>> (I just wrote that wiki page yesterday. Feedback is welcome.)
>
> well, in my case there's no a problem of desktop, it's of application. So, the
> wiki is too much desktop centric. You asked feedback ....
>>
>> Does gazebo require 3D acceleration?
>
> yes ... if relays in OGRE libs.
>
>> If not, try running it with GLX
>> disabled. If you are still having trouble running it, let me know and
>> I'll test gazebo on a KVM/virt-manager Ubuntu 12.04 VM at my home.
>
> I will send you in private a virt machine to test.

Good news and bad news.

Bad News:

It looks like nxagent (and therefore X2Go) is too old to run OGRE apps
linked against Ubuntu 12.04's libraries. Maybe it could be recompiled
against older x server libs and run, but I don't have time to try that
.

I also was unable to run it under cygwin X11 for some reason.

Good News:

I was able to run Gazebo and the OGRE's "SampleBrowser" under KVM &
virt-manager using SPICE and QXL. I am not sure if my host system was
providing the new (experimantal) virtio-gpu or not. The OGRE
SampleBrowser ran surprisingly well.

I successfully did this on both your VM and a VM i created with the
original 12.04 HWE stack.

On your VM, i first ran this command to make sure that the 13.10 HWE X
server and X libraries are installed. You have a bunch of 12.04 HWE X
libraries installed, but they are not supported with the 13.10 kernel
that you have (kernel 3.11).

sudo apt-get install --install-recommends linux-generic-lts-saucy
xserver-xorg-lts-saucy libgl1-mesa-glx-lts-saucy

To run the OGRE SampleBrowser, I ran this package installation command:

sudo apt-get install ogre-samples ogre-tools ogre-doc

Then just run:
SampleBrowser

Screenshots (from my VM, but your's worked too):
http://imgur.com/a/zwPz9

My system:
Host: Fedora 20 64-bit with all the latest updates.
Guest: Ubuntu 12.04 64-bit with original 12.04 HWE stack. Packages
installed include: xubuntu-desktop spice-vdagent libtxc-dxtn-s2tc
Client: virt-viewer 0.6.0 64-bit on Windows

Other notes: On my VM, I installed spice-vdagent. This caused MATE
1.6.0 (from the mate-desktop.org) repo to fail to launch, but it XFCE
still worked. On your VM, it is not installed.

Also, remember that to enable remote SPICE displays, you have to set
the settings on the "Display" in virt-manager. You may have to remove
and add the display for those settings to be adjusted.

> [...]

-Mike#2

Gmane