Vincent | 14 Nov 08:58 2012
Picon

Re: Mac client 'Can't connect to X-Server


Neil Hunt <nwhunt <at> ...> writes:

> 
> Paul,Unfortunately as a regular user of the 
Mac X2go client, this is something I've seen many times. 
Unfortunately, I haven't found any fix for it. 
The good news is that it rarely happens if you keep the X11 
application open. Always open X11 before 
starting your X2go session. From there, you can stop/start 
X2go sessions, even the X2go client itself,
 however I almost always keep my X11 app running even when 
it's not being uses and then I don't get the 
problem you are describing. If I quit X11, especially if it's 
accidental during an active X2go session,
 then I end up with the problem you are describing and the 
only option is to restart the whole computer. 
But if I keep it open, I go for days or weeks without 
rebooting.Ultimately, I think we should look to 
move to the PyHoca gui, but we haven't been able to find 
any serious python developers to port it to OS X.Neil------------
-------------------------------
-------------------------------------------------
> Date: Wed, 6 Jul 2011 12:14:51 -0700
> From: Paul Northug <pnorthug <at> gmail.com>
> To: x2go-user <at> lists.berlios.de
> Subject: [X2go-User] Mac client 'Can't connect to X-Server'
> Message-ID:
>         <CAJAeRZy=KmQsVyoELQ4MrTDHZ8g03x8tXJm
_hTL5NK50jQ9QEw <at> mail.gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1
> Thank you to the developers for make this excellent software.
> Many people at my work use x2go's Mac client. We have never been able
> to figure out how to resolve the 'Can't connect to X-Server' error
> without random acts (eg. rebooting). We are not sure why it comes up.
> This is what I do:
> 1. Start X11.app
> 2. ssh -X remotehost
> 3. xterm &
> So far this works, I get an xterm so there is nothing wrong with X11
> 4. Start X2Go client
> 5. Start a session (port 22, dsa authentication, Gnome...)
> 6. Client gives the error and hangs (Abort and Terminate don't do
> anything) and I have to close the application.
> The closest we got to figuring it out is that the X11.app possibly
> changes it's DISPLAY on restarts and perhaps the x2go client is
> expecting display 0. Is there any more debugging information that I
> could get from the client to see what exactly it is doing prior to
> giving the error message?
> We have tried some of the suggestions in the forums, such as changing
> permissions in X11.app (this is necessary), starting it manually
> before starting the client. We have also done things like messed with
> firewall settings, made sure hostname doesn't change on our laptops
> between work and home, deleted preference files, delete XAuthority
> files, etc. What seems to work is rebooting.
> Thanks,
> P?l
> 
> 
> _______________________________________________
> X2go-User mailing list
> X2go-User <at> ...
> https://lists.berlios.de/mailman/listinfo/x2go-user
> 

I have the exact same problem.
It seems like x2go does something with X11.
Like described, I also start X11 manually and then in works.
But I also noticed that my normal termina
l ssh -X forward does not work.
For that I stop en start X11 then it works.
Then X2go does no longer work, until a reboot.
I tried killing the x processes, but nothing helps.

A solution would be greatly appreciated!

_______________________________________________
X2Go-User mailing list
X2Go-User <at> lists.berlios.de
https://lists.berlios.de/mailman/listinfo/x2go-user

Gmane