Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Jani Frilander <j.frilander-Re5JQEeQqe8AvxtiuMwx3w <at> public.gmane.org>
Subject: Re: Driver for Zoom R16 audio interface
Newsgroups: gmane.linux.usb.general
Date: Monday 1st February 2010 21:31:43 UTC (over 7 years ago)
2010/1/31 Jani Frilander
:
> Hi.
>
> I added lines to alsa-kernel/usb/usbquirks.h:
>
> /* Zoom R16*/
> {
>        .match_flags = USB_DEVICE_ID_MATCH_DEVICE,
>        .idVendor = 0x1686,
>        .idProduct = 0x00dd,
>        .bInterfaceClass = USB_CLASS_AUDIO,
> },
>
> Compiled, and installed modules. Now when I plug the R16
> in, dmesg shows:
>
> [  131.682282] usb 1-6: new high speed USB device using ehci_hcd and
address 4
> [  131.804188] usb 1-6: config 1 interface 3 altsetting 0 bulk
> endpoint 0x1 has invalid maxpacket 64
> [  131.804197] usb 1-6: config 1 interface 3 altsetting 0 bulk
> endpoint 0x82 has invalid maxpacket 64
> [  131.805397] usb 1-6: configuration #1 chosen from 1 choice
> [  132.889369] ALSA usbaudio.c:1293: 4:2:1: cannot get freq at ep 0x84
> [  137.890930] usbcore: registered new interface driver snd-usb-audio
> [  139.013422] ALSA usbaudio.c:1293: 4:1:1: cannot get freq at ep 0x3
>

And replying to my self of course it doesn't work. If I try to play a
file with mplayer:

$ mplayer -msglevel ao=9 -ao alsa:device=hw=2 piisi.mp3
MPlayer UNKNOWN-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote
control.

Playing piisi.mp3.
Audio only file format detected.
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Trying preferred audio driver 'alsa', options 'device=hw=2'
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.20
alsa-init: setup for 1/2 channel(s)
alsa-init: using device hw:2
alsa-init: pcm opened in blocking mode
[AO_ALSA] Format s16le is not supported by hardware, trying default.
[AO_ALSA] Unable to set format: Invalid argument
Failed to initialize audio driver 'alsa:device=hw=2'
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

$ cat /proc/asound/cards
 0 [Audigy         ]: Audigy - SB Audigy 1 [SB0090]
                      SB Audigy 1 [SB0090] (rev.3, serial:0x511102) at
0x9c00, irq 17
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 27
 2 [R16            ]: USB-Audio - R16
                      ZOOM Corporation R16 at usb-0000:00:0b.1-6, high
speed

$ ls /dev/snd/
by-id      controlC2  midiC0D0  midiC2D0  pcmC0D2c  pcmC1D0p  seq
by-path    hwC0D0     midiC0D1  pcmC0D0c  pcmC0D2p  pcmC1D1p  timer
controlC0  hwC0D2     midiC0D2  pcmC0D0p  pcmC0D3p  pcmC2D0c
controlC1  hwC1D0     midiC0D3  pcmC0D1c  pcmC1D0c  pcmC2D0p

What can i do to make it work? I have a wireshark log of a winxp session.
Does it help a bit?

http://sites.google.com/site/zoomr16linux/zoomwire.bz2

Thanks for any advice.

Sincerely, Jani Frilander
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
 
CD: 3ms