Jon Snader | 4 Mar 21:50 2011
Picon

[bug #32681] Geiser does not load the .guile file when invoking guile

Follow-up Comment #2, bug #32681 (project geiser):

I am the original reporter of this bug.  I tried setting the
geiser-guile-init-file to .guile via the configuration but got the same result
(REPL hung). I appended the backtrace from guile at the end of this comment. 
It definitely looks as if it's guile that's barfing not geiser.  I haven't
looked at the guile code for this but it must treat the -l and automatic
.guile load differently.  If I start guile in listen mode and then connect, it
also works correctly.  Let me know if you need further info.

Backtrace:
In module/ice-9/boot-9.scm:
 170: 7 [catch #t #<catch-closure 1012e6080> ...]
In unknown file:
   ?: 6 [catch-closure]
In module/ice-9/boot-9.scm:
  62: 5 [call-with-prompt prompt0 ...]
In module/ice-9/eval.scm:
 389: 4 [eval # #]
In module/ice-9/boot-9.scm:
1917: 3 [save-module-excursion #<procedure 1017b8e40 at
module/ice-9/boot-9.scm:3341:3 ()>]
3346: 2 [#<procedure 1017b8e40 at module/ice-9/boot-9.scm:3341:3 ()>]
In unknown file:
   ?: 1 [load-compiled/vm
"/Users/jcs/.cache/guile/ccache/2.0-LE-8-2.0/Users/jcs/.guile.go"]
In /Users/jcs/.guile:
  43: 0 [#<procedure 10165b640 ()>]

/Users/jcs/.guile:42:0: In procedure #<procedure 10165b640 ()>:
/Users/jcs/.guile:42:0: In procedure module-lookup: Unbound variable:
split-string

    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?32681>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.nongnu.org/


Gmane