John Coy | 8 Jul 00:01 2011
Picon

Re: How to debug nullmailer

The default location of the nullmailer queue on Ubuntu is
/var/spool/nullmailer/queue

My guess for your errors is that your mail provider requires SMTP
authentication for sending mail.  You can change the configuration of the
"remotes" file to supply credentials.  Configuration files are in
/etc/nullmailer/.  You can re-start the service using "service nullmailer
restart" after changing the configuration files.

From the "man remotes" manpage:

remotes
---
This file contains a list of remote servers to which to send each message.
Each line of this file contains a remote host name or address followed by an
optional protocol string, separated by white  space.

The protocol name defaults to smtp, and may be followed by command-line
arguments for that module.  For example, to connect to port 2525 on your
SMTP smart host, which also requires SMTP authentication, use:

    smarthost.dom smtp --port=2525 --user=user --pass=pass

If your smarthost requires LOGIN authentication instead of the default PLAIN
method, use:

    smarthost.dom smtp --port=2525 --auth-login --user=user --pass=pass

Blank lines and lines starting with a pound are ignored.

On 7/7/11 4:37 PM, "Steve Litt" <slitt <at> troubleshooters.com> wrote:

> Hi all,
> 
> I'm running nullmailer on Ubuntu 10.04 LTS, and can't get it to mail,
> and get seemingly infinite error messages. I need to know what steps
> to take to troubleshoot this, and especially how to locate the
> nullmailer queue, which I suspect has some bad stuff in it.
> 
> I don't really know how to use nullmailer after going through the info
> on /usr/share/doc/nullmailer and googling.
> 
> Here's what happens when I run nullmailer-send as root:
> 
> ===========================================
> Sending failed: Permanent error in sending the message
> Starting delivery: protocol: smtp host: mail.a3b3.com file:
> 1309464266.3980
> smtp: Failed: 550-Verification failed for <slitt <at> mydesk.mydesk>/550-
> The mail server could not deliver mail to slitt <at> mydesk.mydesk.  The
> account or domain may not exist, they may be blacklisted, or missing
> the proper dns entries./550 Sender verify failed
> ===========================================
> 
> When I run mailq as root it gives me a long or infinite list of
> messages like this:
> 
> ===========================================
> 2011-03-04 22:04:26 798 bytes from <slitt <at> mydesk.mydesk>
>   to <slitt <at> mydesk.mydesk>
> ===========================================
> 
> I looked all over my machine, did:
> 
> locate nullmailer
> 
> and couldn't find the queue in order to troubleshoot this problem.
> 
> Thanks
> 
> Steve
> 
> Steve Litt
> Recession Relief Package
> http://www.recession-relief.US
> Twitter: http://www.twitter.com/stevelitt
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: nullmailer-unsubscribe <at> lists.untroubled.org
> For additional commands, e-mail: nullmailer-help <at> lists.untroubled.org
> 

Gmane