Home
Reading
Searching
Subscribe
Sponsors
Statistics
Posting
Contact
Spam
Lists
Links
About
Hosting
Filtering
Features Download
Marketing
Archives
FAQ
Blog
 
Gmane
From: Isaac Gonzalez <igonzalez <at> autoreturn.com>
Subject: issues with ldap authentication v. 1.0h on mw 1.8.2
Newsgroups: gmane.org.wikimedia.mediawiki.enterprise
Date: Wednesday 6th December 2006 00:13:02 UTC (over 10 years ago)
It works fine to log me in using my ad username/username password.

 

However, when saving a page, intermittently I get a windows login
prompt, which accepts my ad user/password.

 

I would prefer to only authenticate once to the wiki.

 

Here is my ldap code in localsettings.php:

 

 

/* Ldap Authentication

*/

require_once( "includes/LdapAuthentication.php" );

$wgAuth = new LdapAuthenticationPlugin();

$wgLDAPDomainNames = array( "MYDOMAIN" );

$wgLDAPServerNames = array( " MYDOMAIN "=>"dc1.mydomain.com" );

//$wgLDAPSearchStrings = array( " MYDOMAIN "=>" MYDOMAIN \\USER-NAME" );

$wgLDAPSearchAttributes = array( " MYDOMAIN "=>"sAMAccountName" );

$wgLDAPBaseDNs = array( " MYDOMAIN "=>"dc=mydomain,dc=com" );

$wgLDAPProxyAgent =  "cn=aduser,ou=Services,ou=Users
,dc=mydomain,dc=com";

$wgLDAPProxyAgentPassword = "Mypassword"; //You should also be able to
use a hash!

$wgLDAPUseSSL = false; //not recommended but OK for testing

$wgLDAPUseLocal = true;

$wgMinimalPasswordLength = 1;

$wgLDAPRetrievePrefs = false;

$wgLDAPAddLDAPUsers = false;

$wgLDAPUpdateLDAP = false;

$wgLDAPMailPassword = false;

 

I'm using iis 5 webserver/php 5.1.2/my domain is windows server
2003/ldap plugin v. 1.0h.

 

Any help would be appreciated.

 

-Isaac

 

Isaac Gonzalez

Systems Administrator

AutoReturn

Phone: (415)575-2359

Fax: (415)575-2379
 
CD: 3ms