Ralgh Young | 26 Feb 02:49 2005

Re: compiling pygtk-2.4.1


On Fri, 25 Feb 2005 14:20:38 -0500
"Kirschner, Paul E         UTRC" <KirschPE@...> wrote:

> I have the latest cygwin/gnome setup and am trying to compile pygtk-2.4.1 (I
> gather that the latest pygtk-2.5.4 requires a newer version of GLIB). The
> 2.4.1 compilation fails with...
> 
>  gcc -shared .libs/gobject.dll.def  .libs/gobjectmodule.o .libs/pygboxed.o
> .libs/pygenum.o .libs/pygflags.o .libs/pygobject.o .libs/pygmaincontext.o
> .libs/pygmainloop.o .libs/pygparamspec.o .libs/pygpointer.o .libs/pygtype.o
> -L/usr/lib /usr/lib/libgobject-2.0.dll.a /usr/lib/libgthread-2.0.dll.a
> /usr/lib/libglib-2.0.dll.a /usr/lib/libintl.dll.a /usr/lib/libiconv.dll.a
> -o .libs/gobject.dll -Wl,--image-base=0x10000000
> -Wl,--out-implib,.libs/gobject.dll.a
> Creating library file: .libs/gobject.dll.a
> .libs/gobjectmodule.o(.text+0x17c): In function `pyg_interface_init':
> /home/utrc434/pygtk-2.4.1/gobject/gobjectmodule.c:117: undefined reference
> to `_PyArg_ParseTuple'
> 
> and NUMEROUS other undefined references. 
> 
> I tried hand patching from the 2.2 patches list on the web site to no avail.
> 
> Has anyone gotten this to work? or tried?
> 
> TIA...
> 

Hi,

Seems that the python library wasn't added into LIBADD.
   PYTHON_LIBS = -L/usr/lib/python$(PYTHON_VERSION)/config -lpython$(PYTHON_VERSION)
   gobject_la_LIBADD = $(PYTHON_LIBS) $(GLIB_LIBS)
Then make sure you see '-L/usr/lib/python2.x/config -lpytyhon2.x' in your compile 
command line.

Ralgh Young

-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
http://ads.osdn.com/?ad_id=6595&alloc_id=14396&op=click

Gmane